Meltdown and Spectre vulnerabilites

DIgSILENT is aware of the recently published vulnerabilities commonly known as “Meltdown” and “Spectre” (CVE-2017-5715, CVE-2017-5753, CVE-2017-5754).

These vulnerabilities are based on CPU hardware flaws and potentially affect every software.

To our knowledge, our products PowerFactory and StationWare are not particularly affected, only to the extent that any other software running on vulnerable hardware is.

Until know, we are not aware of any real-life attacks. All attacks have been demonstrated under laboratory conditions only.

However, to be safe, we strongly recommend applying the latest patches for microprocessors and operating systems such as described for MS Windows here.

Go back